MSTP专线由于是光纤通过光猫转换器转换成RJ45的电口到路由器,会导致一个问题,当链路上的光纤有中断时,接到路由器上的电口状态还是UP的,路由器对此无感知,这对我们的监控带来了困扰,因为通常对专线的监控都是监控接口的状态。

根据查询相关资料,监控的方式有以下几种:

  1. 光猫转换器换成光电联动的光猫转换器,这种光猫转换器,光口down后,电口也会down,相应的路由器上的电口也就down了。据说有这种,我没有用过
  2. 思科snmp协议有一个支持远程ping的OID,但是整个过程会很烦锁,当监控多条专线时,需要编程来处理。对这方面有兴趣的可参考:http://www.cnblogs.com/cunshen/articles/163987.html 以及 http://www.cisco.com/c/en/us/support/docs/ip/simple-network-management-protocol-snmp/13383-21.html#examp
  3. 使用路由器的ip sla与eem联动,原理是使用ip sla定时ping对方的接口地址,当发现对方的IP不通后,强制shutdown相应的专线接口。这种方式有一个问题,就是接口shutdown后,在运营商修复线路后,需要人工在设备上启动相应接口,不能自动总是不太好的,特别是节假日无人值班时。可参考http://www.zhaocs.info/sla_eem_1.html

继续阅读

端口聚合指的是把两个或多个物理接口虚拟成一个逻辑的接口,从而增加链路带宽。
cisco交换机聚合端口可以设置三种形式,trunk,access,三层端口。
首先你要判断采用那种接口。

在CISCO 3560交换机上设置如下:
interface Port-channel1
switchport mode trunk
interface FastEthernet0/2
switchport mode trunk
channel-group 1 mode on
interface FastEthernet0/3
switchport mode trunk
channel-group 1 mode on
在华为3100上设置如下
[H3C] link-aggregation group 1 mode manual
[H3C-Ethernet1/0/1] interface ethernet1/0/2
[H3C-Ethernet1/0/2] port link-aggregation group 1
[H3C-Ethernet1/0/2] interface ethernet1/0/3
[H3C-Ethernet1/0/3] port link-aggregation group 1